Emacsをビルドするときにconfigureがうまくいかない場合の対処法 | Trellis Blog

たしか Ubuntu だと libgnutls28-dev を入れても configure スクリプトで認識されなかった。 その場合、 pkg-config を明示的にインストールしてやるとそれらのライブラリが認識されて ビルドが通る。

これは。 configure スクリプトで pkg-config の結果がデフォルト値に設定されていて、 コマンドライン引数でそれを上書きできるという作りになっているからっぽい (だからオプションで指定しても いいはず。面倒臭いけど)。

Last Update: 2019/07/31

Recent Posts

Surface GoにUbuntuをインストール
Ubuntu で freeglut を使う
Unicodeの正規化と濁点